Excel 13. Логическая функция ЕСЛИ

…или кого бы наградить

И в школе, и в фирме, как крупной, так и не очень есть успешные ученики (сотрудники), а есть не очень. В причины успешности-неуспешности вдаваться не буду – не в моей компетенции. Но… успешных людей надо поощрять. И поощрять не потому, что начальник сказал: хочу! А поощрять согласно определенному критерию. Вот такой критерий помогает определить функция ЕСЛИ. И не просто определить критерий, а выдать подсказку: кого наградить, а кого не стоит награждать.

Решаем задачу награждения лучших работников.

Шаг 1. В ячейке I3 набираем слово «Поощрения».

Шаг 2. Делаем активной ячейку I6 и открываем диалоговое окно «Аргументы функции» (лента Функции → группа команд Библиотека функций → функция Логические → функция ЕСЛИ):

Логическая функция ЕСЛИ

Появится диалоговое окно «Аргументы функции».

Шаг 3. В первом поле «Лог_выражение» отмечаем ячейку Н6:

функция ЕСЛИ

Внимательно изучаем диалоговое окно «Аргументы функции»:

функция ЕСЛИ
  1. Выражение в ячейке Н6, которое является в этой формуле истиной в последней инстанции
  2. Что должно появится в ячейке, если содержимое ячейки Н6 удовлетворяет условию, записанному в поле «Лог_выражение» (набираем с клавиатуры вручную)
  3. Что должно появится в ячейке, если содержимое ячейки Н6 не удовлетворяет условию, записанному в поле «Лог_выражение» (набираем с клавиатуры вручную)

Отмечаем два момента:

Понять и запомнить!1. «=<2» пишем вручную. Я пробовала через буфер обмена вставить «≤», увы, не сработало
2. Текстовая информация, которая должна появиться в результате выполнения или невыполнения условия, ОБЯЗАТЕЛЬНО заключена в кавычки. Даже обычный одиночный пробел заключаем в кавычки.

Шаг 4. Копируем формулу на другие ячейки (тянем за зеленый квадратик в правом нижнем углу ячейки – курсор имеет вид черного креста):

Логическая функция ЕСЛИ

Формула выглядит так:

=ЕСЛИ(H6<=2;”Поощрить”;”Не поощрять”)

Как часто нам приходится искать в жизни лучшее:

  1. лучшего ученика
  2. самую дорогую покупку
  3. самую толстую книгу
  4. самую читаемую книгу

Усложним задачу. На третьем месте стоит работник, который принес компании немаленькую сумму 68500 р, вдвое бо̀льшую, чем работники на четвертом и пятом месте. Я считаю, что его тоже надо поощрить. Поэтому в следующей статье зададим выполнение сложного условия: наградим не только сотрудников первого и второго ранга, но и сотрудников, которые заработали для компании более 50000 р.

Оставьте первый комментарий

Комментировать