Excel 16. Сумма с учетом условий

Решаем задачу: суммируем общий доход только тех сотрудников, чей доход больше 50000. Тем самых мы определяем наиболее успешных сотрудников.

Шаг 1. В ячейку G6 вводим выражение «Сумма>50000». Это будет название.

Шаг 2. В ячейку G6 будет вычисляться сумма с учетом условий (вводим функцию суммы при определенных условиях «СУММЕСЛИ» (знак «=» и «су» в русском регистре)):

Сумма с учетом условий

Появляется выпадающее меню, в котором представлен перечень функций, начинающиеся на «су».

Шаг 3. Выбираем функцию «СУММЕСЛИ» (выбор из выпадающего меню и двойной щелчок ЛМ по имени функции в меню)

Шаг 4. Определяем диапазон суммирования, где будет вычисляться сумма с учетом условий:

Сумма с учетом условий

Шаг 5. Вводим «;» (точка с запятой) и выражение «”>50000″»:

Сумма с учетом условий

Кавычки обязательны!!!

Шаг 6. Нажимаем Enter:

Сумма с учетом условий

Формула выглядит так:

=СУММЕСЛИ(G6:G10;”>50000″)

Сумма с учетом условий готова! В данном случае у нас одно условие.

Если вы хотите работать с диалоговым окном «Аргументы функции»

Шаг 1. Находим функцию «СУММЕСЛИ» (лента Формула → группа команд Библиотека функций → категория Математические → функция СУММЕСЛИ):

Аргументы функции СУММЕСЛИ

Шаг 2. Вводим следующие значения в поля:

Аргументы функции СУММЕСЛИ

Я не работаю в сфере торговли. Я работаю с большим объемом самых разных документов и презентаций. Мне очень удобно вести базу данных в Excel’е. Я подсчитываю:

  1. Количество документов (отвечающих определенным условиям)
  2. Количество страниц в документах (слайдов презентации)
  3. Степень готовности документов по определенным условиям.
  4. Степень важности документов
  5. Тематика документов
  6. Заказчики документов и много другое

Excel помогает мне видеть наглядно ход развития очередного проекта и при необходимости готовить отчет для начальства.

И, конечно, главные выводы по пяти урокам:

  1. Аргументы разделяются точкой с запятой
  2. Аргумент может быть вложенной функцией. Например, =ЕСЛИ(И(условие;условие);”значение, если ИСТИНА”;”значение, Если ЛОЖЬ”). ЕСЛИ основная функция, а функция И является аргументом. В этом случае в аргументе-функции будут свои аргументы. И они, в свою очередь, тоже будут разделяться точкой с запятой (хорошо, что мы только два условия записали, а не 255)
  3. Любая текстовая информация в формуле должна быть заключена в кавычки
  4. Число открывающихся скобок должно равняться числу закрывающихся скобок. Когда я пишу формулу, то в конце занимаюсь именно подсчетом скобок, но если я ошибусь, то Excel любезно выдаст мне диагностику:

Если в формуле будет незначительная ошибка, то Excel предложит исправить опечатку:

И совсем дело плохо при такой диагностике:

В этом случае лучше начать сначала. Поэтому я желаю вам соблюдать всегда синтаксис Excel и полюбить формулы!

Оставьте первый комментарий

Комментировать